diff setup.py @ 4:f8612f05af99

Added first stab of an implementation of the !TurboGears [http://www.turbogears.org/docs/plugins/template.html plugin API for template engines], and also a !TurboGears-based example using this plugin. Both written by Matt Good.
author cmlenz
date Sat, 03 Jun 2006 12:31:58 +0000
parents 821114ec4f69
children b8456279c444
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -21,5 +21,9 @@
     license='BSD', url='http://markup.cmlenz.net/',
     packages=find_packages(exclude=['*.tests*']),
     test_suite = 'markup.tests.suite',
-    zip_safe = True
+    zip_safe = True,
+    entry_points = """
+    [python.templating.engines]
+    markup = markup.plugin:TemplateEnginePlugin
+    """,
 )
Copyright (C) 2012-2017 Edgewall Software