diff setup.py @ 148:a0a52cf4e4de

Added changelog file, plus some README and setup tweaks.
author cmlenz
date Tue, 15 Aug 2006 14:41:08 +0000
parents 56d534eb53f9
children 8709e8fbc6ef 7f2a267837d0
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -18,11 +18,20 @@
     from distutils.core import setup
 
 setup(
-    name='Markup', version='0.2',
-    description='Toolkit for stream-based generation of markup for the web',
-    author='Edgewall Software', author_email='info@edgewall.org',
-    license='BSD', url='http://markup.edgewall.org/',
-    download_url='http://markup.edgewall.org/wiki/MarkupDownload',
+    name = 'Markup',
+    version = '0.2',
+    description = 'Toolkit for stream-based generation of markup for the web',
+    long_description = \
+'''Markup is a Python library that provides an integrated set of components for
+parsing, generating, and processing HTML or XML content in a uniform manner.
+The major feature is a template language that is heavily inspired by Kid.''',
+    author = 'Edgewall Software',
+    author_email = 'info@edgewall.org',
+    license = 'BSD',
+    url = 'http://markup.edgewall.org/',
+    download_url = 'http://markup.edgewall.org/wiki/MarkupDownload',
+    zip_safe = True,
+
     classifiers = [
         'Development Status :: 4 - Beta',
         'Environment :: Web Environment',
@@ -35,13 +44,12 @@
         'Topic :: Text Processing :: Markup :: HTML',
         'Topic :: Text Processing :: Markup :: XML'
     ],
-
     packages=['markup'],
+    test_suite = 'markup.tests.suite',
 
-    test_suite = 'markup.tests.suite',
-    zip_safe = True,
+    extras_require = {'plugin': ['setuptools>=0.6a2']},
     entry_points = """
     [python.templating.engines]
-    markup = markup.plugin:TemplateEnginePlugin
+    markup = markup.plugin:TemplateEnginePlugin[plugin]
     """,
 )
Copyright (C) 2012-2017 Edgewall Software