diff setup.py @ 265:0f2bc982a2b9

Split up the plugin implementation into two classes: one for markup templates (?genshi-markup? or just ?genshi?) and one for text templates (?genshi-text?). Also added an example for plain-text templating to the TurboGears example app.
author cmlenz
date Fri, 22 Sep 2006 17:22:53 +0000
parents 3ea3977c8c4d
children 5f2c7782cd8a
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -52,6 +52,8 @@
     extras_require = {'plugin': ['setuptools>=0.6a2']},
     entry_points = """
     [python.templating.engines]
-    genshi = genshi.plugin:TemplateEnginePlugin[plugin]
+    genshi = genshi.plugin:MarkupTemplateEnginePlugin[plugin]
+    genshi-markup = genshi.plugin:MarkupTemplateEnginePlugin[plugin]
+    genshi-text = genshi.plugin:TextTemplateEnginePlugin[plugin]
     """,
 )
Copyright (C) 2012-2017 Edgewall Software