diff setup.py @ 99:efc1eed69ba8

Make Bitten deployable in Trac as a [http://peak.telecommunity.com/DevCenter/PythonEggs Python egg].
author cmlenz
date Mon, 18 Jul 2005 17:35:21 +0000
parents 001f77d05cdc
children 4bee62474361
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,11 @@
 #
 # Author: Christopher Lenz <cmlenz@gmx.de>
 
-from distutils.core import setup
+import ez_setup # From http://peak.telecommunity.com/DevCenter/setuptools
+ez_setup.use_setuptools()
+
+
+from setuptools import setup, find_packages
 from distutils import util
 from glob import glob
 
@@ -30,9 +34,9 @@
 if util.get_platform()[:3] == 'win':
     scripts = [script + '.bat' for script in scripts]
 
-setup(name='bitten', version=VERSION,
-      packages=['bitten', 'bitten.build', 'bitten.trac_ext', 'bitten.util'],
-      data_files=[('share/bitten/htdocs', glob('htdocs/*.*')),
-                  ('share/bitten/templates', glob('templates/*.cs'))],
-      scripts=scripts, author="Christopher Lenz", author_email="cmlenz@gmx.de",
-      url="http://bitten.cmlenz.net/", cmdclass={'unittest': unittest})
+setup(name='bitten', version=VERSION, author="Christopher Lenz",
+      author_email="cmlenz@gmx.de", url="http://bitten.cmlenz.net/",
+      packages=find_packages(exclude=["*.tests*"]),
+      package_data={'bitten.trac_ext': ['templates/*.cs', 'htdocs/*.*']},
+      scripts=scripts, test_suite='bitten.tests.suite', zip_safe=True,
+      cmdclass={'unittest': unittest})
Copyright (C) 2012-2017 Edgewall Software