diff setup.py @ 163:634be6cbb808

Flip the switch: Bitten is now BSD-licensed.
author cmlenz
date Sat, 27 Aug 2005 07:58:12 +0000
parents dd745d6b8c83
children b1f6b666aed6
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -2,22 +2,11 @@
 # -*- coding: iso8859-1 -*-
 #
 # Copyright (C) 2005 Christopher Lenz <cmlenz@gmx.de>
-#
-# Bitten is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of the
-# License, or (at your option) any later version.
+# All rights reserved.
 #
-# Trac is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-#
-# Author: Christopher Lenz <cmlenz@gmx.de>
+# This software is licensed as described in the file COPYING, which
+# you should have received as part of this distribution. The terms
+# are also available at http://bitten.cmlenz.net/wiki/License.
 
 from setuptools import setup, find_packages
 
@@ -28,6 +17,7 @@
       author_email='cmlenz@gmx.de', url='http://bitten.cmlenz.net/',
       description='Framework for collecting software metrics via continuous '
                   'integration',
+      license='BSD',
       packages=find_packages(exclude=['ez_setup', '*.tests*']),
       package_data={'bitten.trac_ext': ['templates/*.cs', 'htdocs/*.*']},
       scripts=['scripts/bitten', 'scripts/bittend'],
Copyright (C) 2012-2017 Edgewall Software