diff setup.py @ 213:25f84dd9f159

* Refactoring of build recipes, the file format has changed slightly: * The namespace URIs of recipe command collections are now abstract, implementations are registered using setuptools entry points. * Commands for report generation are no longer nested in a `<reports>` sub-element, but are at the same level as normal commands. * Fixed linking to files from the test results and code coverage summarizers. * Windows file separators are normalized to a forward slash by recipe commands (thereby also fixing linking to the repository browser from report summaries). * Paths using backslashes as file separators are now recognized in build logs in the web interface, and linked to the repository browser. * The `generator` column in the build log and report tables now has the qualified name of the recipe command that generated the log messages or report data. * There's a database upgrade script to fix file separator normalization and generator values for existing reports and build logs.
author cmlenz
date Tue, 20 Sep 2005 22:16:41 +0000
parents 0781987c586a
children 832e64330c31
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,8 @@
 from bitten import __version__ as VERSION
 from bitten.util.testrunner import unittest
 
+NS = 'http://bitten.cmlenz.net/tools/'
+
 setup(
     name='Bitten', version=VERSION, author='Christopher Lenz',
     author_email='cmlenz@gmx.de', url='http://bitten.cmlenz.net/',
@@ -26,13 +28,29 @@
                             'templates/*.cs']
     },
     entry_points = {
-        'console_scripts': ['bitten-master = bitten.master:main',
-                            'bitten-slave = bitten.slave:main'],
-        'distutils.commands': ['unittest = bitten.util.testrunner:unittest'],
-        'trac.plugins': ['bitten.main = bitten.trac_ext.main',
-                         'bitten.web_ui = bitten.trac_ext.web_ui',
-                         'bitten.summarizers = bitten.trac_ext.summarizers',
-                         'bitten.charts = bitten.trac_ext.charts']
+        'console_scripts': [
+            'bitten-master = bitten.master:main',
+            'bitten-slave = bitten.slave:main'
+        ],
+        'distutils.commands': [
+            'unittest = bitten.util.testrunner:unittest'
+        ],
+        'trac.plugins': [
+            'bitten.main = bitten.trac_ext.main',
+            'bitten.web_ui = bitten.trac_ext.web_ui',
+            'bitten.summarizers = bitten.trac_ext.summarizers',
+            'bitten.charts = bitten.trac_ext.charts'
+        ],
+        'bitten.recipe_commands': [
+            NS + 'sh#exec = bitten.build.shtools:exec_',
+            NS + 'sh#pipe = bitten.build.shtools:pipe',
+            NS + 'c#make = bitten.build.ctools:make',
+            NS + 'python#distutils = bitten.build.pythontools:distutils',
+            NS + 'python#exec = bitten.build.pythontools:exec_',
+            NS + 'python#pylint = bitten.build.pythontools:pylint',
+            NS + 'python#trace = bitten.build.pythontools:trace',
+            NS + 'python#unittest = bitten.build.pythontools:unittest'
+        ]
     },
     test_suite='bitten.tests.suite', zip_safe=True
 )
Copyright (C) 2012-2017 Edgewall Software