diff setup.py @ 68:234600bf0d49

Fixes for Windows compatibility: * implementation of {{{bitten.util.cmdline}}} for windows, based on temporary files * the recipe tools now close the files they opened so that they can be properly deleted after the build completed * Wrapper batch files for client and server
author cmlenz
date Thu, 30 Jun 2005 12:28:54 +0000
parents ab569c55c835
children 001f77d05cdc
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -20,12 +20,16 @@
 # Author: Christopher Lenz <cmlenz@gmx.de>
 
 from distutils.core import setup
+from distutils import util
 
 from bitten import __version__ as VERSION
 from bitten.util.testrunner import unittest
 
+scripts = ['scripts/bitten', 'scripts/bittend']
+if util.get_platform()[:3] == 'win':
+    scripts = [script + '.bat' for script in scripts]
+
 setup(name='bitten', version=VERSION,
       packages=['bitten', 'bitten.build', 'bitten.trac_ext', 'bitten.util'],
-      scripts=['scripts/bitten', 'scripts/bittend'],
-      author="Christopher Lenz", author_email="cmlenz@gmx.de",
+      scripts=scripts, author="Christopher Lenz", author_email="cmlenz@gmx.de",
       url="http://bitten.cmlenz.net/", cmdclass={'unittest': unittest})
Copyright (C) 2012-2017 Edgewall Software