diff setup.py @ 0:0b2a3581c48d

Import initial ''bitten'' source.
author cmlenz
date Sun, 22 May 2005 15:49:22 +0000
parents
children 32e9f0e94c69
line wrap: on
line diff
new file mode 100644
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,25 @@
+from distutils.core import setup, Command
+from unittest import TextTestRunner
+
+
+class test(Command):
+    description = "Runs the unit tests"
+    user_options = [('test-suite=', 's', "Name of the unittest suite to run")]
+
+    def initialize_options(self):
+        self.test_suite = None
+
+    def finalize_options(self):
+        pass
+
+    def run(self):
+        print 'Hey yo'
+        print self.test_suite
+        suite = __import__(self.test_suite, locals(), globals())
+        runner = unittest.TextTestRunner()
+        TextTestRunner.run(suite)
+
+
+setup(name='bitten', version='1.0',
+      packages=['bitten', 'bitten.general', 'bitten.python'],
+      cmdclass={'test': test})
Copyright (C) 2012-2017 Edgewall Software