diff setup.py @ 427:04f76d061ad5

Fix for #166. This means the `unittest` command will only be available for the Bitten setup itself after Bitten has been installed. In general this isn't a problem, because you can simply use the regular `test` command to run the tests.
author cmlenz
date Sun, 12 Aug 2007 21:52:14 +0000
parents ff35be7d2a5e
children d6e1a05f32f7
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -13,8 +13,6 @@
 from setuptools import setup, find_packages
 import sys
 
-from bitten.util.testrunner import unittest
-
 sys.path.append(os.path.join('doc', 'common'))
 try:
     from doctools import build_doc, test_doc
@@ -36,13 +34,13 @@
     download_url = 'http://bitten.edgewall.org/wiki/Download',
     zip_safe = False,
 
-    packages=find_packages(exclude=['*.tests*']),
-    package_data={
+    packages = find_packages(exclude=['*.tests*']),
+    package_data = {
         'bitten': ['htdocs/*.*',
                    'htdocs/charts_library/*.swf',
                    'templates/*.cs']
     },
-    test_suite='bitten.tests.suite',
+    test_suite = 'bitten.tests.suite',
     entry_points = {
         'console_scripts': [
             'bitten-slave = bitten.slave:main'
@@ -82,6 +80,5 @@
         ]
     },
 
-    cmdclass = {'build_doc': build_doc, 'test_doc': test_doc,
-                'unittest': unittest}
+    cmdclass = {'build_doc': build_doc, 'test_doc': test_doc}
 )
Copyright (C) 2012-2017 Edgewall Software